CVE-2019-13045

NameCVE-2019-13045
DescriptionIrssi before 1.0.8, 1.1.x before 1.1.3, and 1.2.x before 1.2.1, when SASL is enabled, has a use after free when sending SASL login to the server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs931264

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)jessie (security), jessie0.8.17-1+deb8u5fixed
stretch (security), stretch1.0.7-1~deb9u1vulnerable
buster1.2.0-2vulnerable
bullseye, sid1.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisource(unstable)1.2.1-1low931264
irssisourcejessie(not affected)

Notes

[buster] - irssi <no-dsa> (Minor issue)
[stretch] - irssi <no-dsa> (Minor issue)
[jessie] - irssi <not-affected> (vulnerable sasl code is not present)
https://irssi.org/security/irssi_sa_2019_06.txt
https://github.com/irssi/irssi/pull/1058
https://github.com/irssi/irssi/commit/5a67b983dc97caeb5df1139aabd0bc4f260a47d8
Fixed in 1.0.8, 1.1.3, 1.2.1

Search for package or bug name: Reporting problems