CVE-2019-13132

NameCVE-2019-13132
DescriptionIn ZeroMQ libzmq before 4.0.9, 4.1.x before 4.1.7, and 4.2.x before 4.3.2, a remote, unauthenticated client connecting to a libzmq application, running with a socket listening with CURVE encryption/authentication enabled, may cause a stack overflow and overwrite the stack with arbitrary data, due to a buffer overflow in the library. Users running public servers with the above configuration are highly encouraged to upgrade as soon as possible, as there are no known mitigations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1849-1, DSA-4477-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zeromq3 (PTS)jessie4.0.5+dfsg-2+deb8u1vulnerable
jessie (security)4.0.5+dfsg-2+deb8u2fixed
stretch4.2.1-4+deb9u1vulnerable
stretch (security)4.2.1-4+deb9u2fixed
buster4.3.1-4vulnerable
buster (security)4.3.1-4+deb10u1fixed
bullseye, sid4.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zeromq3source(unstable)4.3.1-5high
zeromq3sourcebuster4.3.1-4+deb10u1highDSA-4477-1
zeromq3sourcejessie4.0.5+dfsg-2+deb8u2highDLA-1849-1
zeromq3sourcestretch4.2.1-4+deb9u2highDSA-4477-1

Notes

https://github.com/zeromq/libzmq/issues/3558

Search for package or bug name: Reporting problems