CVE-2019-13164

NameCVE-2019-13164
Descriptionqemu-bridge-helper.c in QEMU 4.0.0 does not ensure that a network interface name (obtained from bridge.conf or a --br=bridge option) is limited to the IFNAMSIZ size, which can lead to an ACL bypass.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4506-1
NVD severitymedium (attack range: local)
Debian Bugs931351

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u11vulnerable
stretch1:2.8+dfsg-6+deb9u5vulnerable
stretch (security)1:2.8+dfsg-6+deb9u8fixed
buster1:3.1+dfsg-8~deb10u1vulnerable
bullseye, sid1:3.1+dfsg-8vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)(unfixed)medium931351
qemusourcestretch1:2.8+dfsg-6+deb9u8mediumDSA-4506-1
qemu-kvmsource(unstable)(unfixed)medium

Notes

[buster] - qemu <postponed> (Minor issue, can be fixed along in future DSA)
https://lists.gnu.org/archive/html/qemu-devel/2019-07/msg00245.html

Search for package or bug name: Reporting problems