CVE-2019-13241

NameCVE-2019-13241
DescriptionFlightCrew v0.9.2 and older are vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flightcrew (PTS)buster0.7.2+dfsg-13+deb10u1fixed
bookworm, sid, bullseye0.9.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flightcrewsourcestretch0.7.2+dfsg-9+deb9u1
flightcrewsourcebuster0.7.2+dfsg-13+deb10u1
flightcrewsource(unstable)0.7.2+dfsg-14

Notes

https://github.com/Sigil-Ebook/flightcrew/issues/52

Search for package or bug name: Reporting problems