CVE-2019-1352

NameCVE-2019-1352
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2059-1, DSA-4581-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
git (PTS)jessie1:2.1.4-2.1+deb8u6vulnerable
jessie (security)1:2.1.4-2.1+deb8u8fixed
stretch1:2.11.0-3+deb9u4vulnerable
stretch (security)1:2.11.0-3+deb9u5fixed
buster1:2.20.1-2vulnerable
buster (security)1:2.20.1-2+deb10u1fixed
bullseye1:2.24.1-1fixed
sid1:2.25.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitsource(unstable)1:2.24.0-2
gitsourcebuster1:2.20.1-2+deb10u1DSA-4581-1
gitsourcejessie1:2.1.4-2.1+deb8u8DLA-2059-1
gitsourcestretch1:2.11.0-3+deb9u5DSA-4581-1

Notes

https://git.kernel.org/pub/scm/git/git.git/commit/?id=7c3745fc6185495d5765628b4dfe1bd2c25a2981
https://www.openwall.com/lists/oss-security/2019/12/13/1
Additional hardening for .gitmodules (but not part of the CVE):
https://git.kernel.org/pub/scm/git/git.git/commit/?id=91bd46588e6959e6903e275f78b10bd07830d547

Search for package or bug name: Reporting problems