CVE-2019-1353

NameCVE-2019-1353
DescriptionAn issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v2.20.2, v2.19.3, v2.18.2, v2.17.3, v2.16.6, v2.15.4, and v2.14.6. When running Git in the Windows Subsystem for Linux (also known as "WSL") while accessing a working directory on a regular Windows drive, none of the NTFS protections were active.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2059-1, DSA-4581-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
git (PTS)stretch1:2.11.0-3+deb9u5fixed
stretch (security)1:2.11.0-3+deb9u7fixed
buster, buster (security)1:2.20.1-2+deb10u3fixed
bullseye, sid1:2.27.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitsource(unstable)1:2.24.0-2
gitsourcebuster1:2.20.1-2+deb10u1DSA-4581-1
gitsourcejessie1:2.1.4-2.1+deb8u8DLA-2059-1
gitsourcestretch1:2.11.0-3+deb9u5DSA-4581-1

Notes

https://git.kernel.org/pub/scm/git/git.git/commit/?id=9102f958ee5254b10c0be72672aa3305bf4f4704
https://www.openwall.com/lists/oss-security/2019/12/13/1

Search for package or bug name: Reporting problems