CVE-2019-13574

NameCVE-2019-13574
DescriptionIn lib/mini_magick/image.rb in MiniMagick before 4.9.4, a fetched remote image filename could cause remote command execution because Image.open input is directly passed to Kernel#open, which accepts a '|' character followed by a command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4481-1
NVD severitymedium (attack range: remote)
Debian Bugs931932

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-mini-magick (PTS)jessie3.8.1-1vulnerable
stretch4.5.1-1vulnerable
stretch (security)4.5.1-1+deb9u1fixed
buster4.9.2-1vulnerable
buster (security)4.9.2-1+deb10u1fixed
bullseye, sid4.9.2-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-mini-magicksource(unstable)4.9.2-1.1medium931932
ruby-mini-magicksourcebuster4.9.2-1+deb10u1mediumDSA-4481-1
ruby-mini-magicksourcestretch4.5.1-1+deb9u1mediumDSA-4481-1

Search for package or bug name: Reporting problems