CVE-2019-13602

NameCVE-2019-13602
DescriptionAn Integer Underflow in MP4_EIA608_Convert() in modules/demux/mp4/mp4.c in VideoLAN VLC media player through 3.0.7.1 allows remote attackers to cause a denial of service (heap-based buffer overflow and crash) or possibly have unspecified other impact via a crafted .mp4 file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4504-1
NVD severitymedium (attack range: remote)
Debian Bugs932131

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)jessie (security), jessie2.2.7-1~deb8u1vulnerable
stretch3.0.6-0+deb9u1vulnerable
stretch (security)3.0.8-0+deb9u1fixed
buster3.0.7-1vulnerable
buster (security)3.0.8-0+deb10u1fixed
bullseye, sid3.0.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)3.0.7.1-2medium932131
vlcsourcebuster3.0.8-0+deb10u1mediumDSA-4504-1
vlcsourcejessie(unfixed)end-of-life
vlcsourcestretch3.0.8-0+deb9u1mediumDSA-4504-1

Notes

[jessie] - vlc <end-of-life> (https://lists.debian.org/debian-security-announce/2018/msg00130.html)
https://git.videolan.org/?p=vlc.git;a=commit;h=8e8e0d72447f8378244f5b4a3dcde036dbeb1491
https://git.videolan.org/?p=vlc.git;a=commit;h=b2b157076d9e94df34502dd8df0787deb940e938
https://www.videolan.org/security/sb-vlc308.html

Search for package or bug name: Reporting problems