CVE-2019-13626

NameCVE-2019-13626
DescriptionSDL (Simple DirectMedia Layer) 2.x through 2.0.9 has a heap-based buffer over-read in Fill_IMA_ADPCM_block, caused by an integer overflow in IMA_ADPCM_decode() in audio/SDL_wave.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3314-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsdl1.2 (PTS)buster1.2.15+dfsg2-6~deb10u1fixed
bullseye1.2.15+dfsg2-6fixed
bookworm1.2.15+dfsg2-8fixed
libsdl2 (PTS)buster2.0.9+dfsg1-1vulnerable
buster (security)2.0.9+dfsg1-1+deb10u1fixed
bullseye2.0.14+dfsg2-3+deb11u1fixed
bookworm2.26.5+dfsg-1fixed
trixie2.30.3+dfsg-1fixed
sid2.30.4+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsdl1.2source(unstable)(not affected)
libsdl2sourcebuster2.0.9+dfsg1-1+deb10u1DLA-3314-1
libsdl2source(unstable)2.0.10+dfsg1-1

Notes

[stretch] - libsdl2 <no-dsa> (Minor issue)
[jessie] - libsdl2 <no-dsa> (Minor issue)
- libsdl1.2 <not-affected> (Vulnerable code added later)
https://bugzilla.libsdl.org/show_bug.cgi?id=4522
24-bit PCM WAVE introduced in SDL 2.0

Search for package or bug name: Reporting problems