CVE-2019-13952

NameCVE-2019-13952
DescriptionThe set_ipv6() function in zscan_rfc1035.rl in gdnsd before 2.4.3 and 3.x before 3.2.1 has a stack-based buffer overflow via a long and malformed IPv6 address in zone data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs932407

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gdnsd (PTS)jessie2.1.2-1~deb8u1vulnerable
stretch2.2.4-1vulnerable
bullseye, sid, buster2.4.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gdnsdsource(unstable)(unfixed)unimportant932407

Notes

https://github.com/gdnsd/gdnsd/issues/185
No security impact, data is under administrative control
Patches: https://github.com/gdnsd/gdnsd/issues/185#issuecomment-513288786

Search for package or bug name: Reporting problems