CVE-2019-14452

NameCVE-2019-14452
DescriptionSigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs933797

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sigil (PTS)stretch0.9.7+dfsg-1vulnerable
buster0.9.13+dfsg-1vulnerable
bullseye, sid1.2.1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sigilsource(unstable)0.9.16+dfsg-1933797

Notes

[buster] - sigil <no-dsa> (Minor issue)
[stretch] - sigil <no-dsa> (Minor issue)
https://github.com/Sigil-Ebook/Sigil/commit/04e2f280cc4a0766bedcc7b9eb56449ceecc2ad4
https://github.com/Sigil-Ebook/Sigil/commit/0979ba8d10c96ebca330715bfd4494ea0e019a8f
https://github.com/Sigil-Ebook/Sigil/commit/369eebe936e4a8c83cc54662a3412ce8bef189e4

Search for package or bug name: Reporting problems