CVE-2019-14494

NameCVE-2019-14494
DescriptionAn issue was discovered in Poppler through 0.78.0. There is a divide-by-zero error in the function SplashOutputDev::tilingPatternFill at SplashOutputDev.cc.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2440-1, DLA-3120-1
Debian Bugs933812

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)bullseye (security), bullseye20.09.0-3.1+deb11u1fixed
bookworm22.12.0-2fixed
sid, trixie24.02.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersourceexperimental0.81.0-1
popplersourcestretch0.48.0-2+deb9u4DLA-2440-1
popplersourcebuster0.71.0-5+deb10u1DLA-3120-1
popplersource(unstable)0.85.0-2933812

Notes

[jessie] - poppler <no-dsa> (Minor issue)
https://gitlab.freedesktop.org/poppler/poppler/issues/802
https://gitlab.freedesktop.org/poppler/poppler/merge_requests/317
https://gitlab.freedesktop.org/poppler/poppler/commit/b224e2f5739fe61de9fa69955d016725b2a4b78d

Search for package or bug name: Reporting problems