CVE-2019-14776

NameCVE-2019-14776
DescriptionA heap-based buffer over-read exists in DemuxInit() in demux/asf/asf.c in VideoLAN VLC media player 3.0.7.1 via a crafted .mkv file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4504-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)jessie (security), jessie2.2.7-1~deb8u1vulnerable
stretch (security), stretch3.0.8-0+deb9u1fixed
buster, buster (security)3.0.8-0+deb10u1fixed
bullseye, sid3.0.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)3.0.8-1
vlcsourcebuster3.0.8-0+deb10u1DSA-4504-1
vlcsourcejessie(unfixed)end-of-life
vlcsourcestretch3.0.8-0+deb9u1DSA-4504-1

Notes

[jessie] - vlc <end-of-life> (https://lists.debian.org/debian-security-announce/2018/msg00130.html)
https://www.videolan.org/security/sb-vlc308.html

Search for package or bug name: Reporting problems