CVE-2019-14813

NameCVE-2019-14813
DescriptionA flaw was found in ghostscript, versions 9.x before 9.28, in the setsystemparams procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1915-1, DSA-4518-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie9.06~dfsg-2+deb8u7vulnerable
jessie (security)9.26a~dfsg-0+deb8u5fixed
stretch9.26a~dfsg-0+deb9u4vulnerable
stretch (security)9.26a~dfsg-0+deb9u5fixed
buster9.27~dfsg-2+deb10u1vulnerable
buster (security)9.27~dfsg-2+deb10u2fixed
bullseye9.27~dfsg-3.1vulnerable
sid9.28~~rc3~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.28~~rc2~dfsg-1high
ghostscriptsourcebuster9.27~dfsg-2+deb10u2highDSA-4518-1
ghostscriptsourcejessie9.26a~dfsg-0+deb8u5highDLA-1915-1
ghostscriptsourcestretch9.26a~dfsg-0+deb9u5highDSA-4518-1

Notes

https://bugs.ghostscript.com/show_bug.cgi?id=701443
http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=885444fcbe10dc42787ecb76686c8ee4dd33bf33
https://www.openwall.com/lists/oss-security/2019/08/28/2
For recent versions (9.28~~rc1~dfsg-1) the issue is mitigated starting
from http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=7ecbfda92b4c8dbf6f6c2bf8fc82020a29219eff
which changed the access to file permissions.

Search for package or bug name: Reporting problems