CVE-2019-14846

NameCVE-2019-14846
DescriptionAnsible, all ansible_engine-2.x versions and ansible_engine-3.x up to ansible_engine-3.5, was logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2202-1
NVD severitylow
Debian Bugs942188

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)jessie1.7.2+dfsg-2vulnerable
jessie (security)1.7.2+dfsg-2+deb8u3fixed
stretch (security), stretch2.2.1.0-2+deb9u1vulnerable
buster2.7.7+dfsg-1vulnerable
bullseye, sid2.9.9+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesource(unstable)2.8.6+dfsg-1low942188
ansiblesourcejessie1.7.2+dfsg-2+deb8u3DLA-2202-1

Notes

[buster] - ansible <no-dsa> (Minor issue)
[stretch] - ansible <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1755373
https://github.com/ansible/ansible/pull/63366
https://github.com/ansible/ansible/commit/90e74dd2600e5cc42dd9b4f4656f3d651c4ce5c4

Search for package or bug name: Reporting problems