|Description||In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)|
|References||DLA-2202-1, DLA-2535-1, DSA-4950-1|
Vulnerable and fixed packages
The table below lists information on source packages.
|ansible (PTS)||buster, buster (security)||2.7.7+dfsg-1+deb10u1||fixed|
The information below is based on the following data on fixed versions.