CVE-2019-15117

NameCVE-2019-15117
Descriptionparse_audio_mixer_unit in sound/usb/mixer.c in the Linux kernel through 5.2.9 mishandles a short descriptor, leading to out-of-bounds memory access.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1930-1, DLA-1940-1, DSA-4531-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.76-1fixed
stretch4.9.189-3vulnerable
stretch (security)4.9.189-3+deb9u2fixed
buster4.19.67-2+deb10u1fixed
buster (security)4.19.67-2+deb10u2fixed
bullseye, sid5.3.9-3fixed
linux-4.9 (PTS)jessie (security)4.9.189-3+deb9u2~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.2.17-1
linuxsourcebuster4.19.67-2+deb10u1DSA-4531-1
linuxsourcejessie3.16.74-1DLA-1930-1
linuxsourcestretch4.9.189-3+deb9u1DSA-4531-1
linux-4.9sourcejessie4.9.189-3+deb9u1~deb8u1DLA-1940-1

Notes

Fixed by: https://git.kernel.org/linus/daac07156b330b18eb5071aec4b3ddca1c377f2c

Search for package or bug name: Reporting problems