CVE-2019-15161

NameCVE-2019-15161
Descriptionrpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a variable. This may open up an attack vector involving extra data at the end of a request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpcap (PTS)buster1.8.1-6+deb10u1fixed
bullseye1.10.0-2fixed
bookworm, sid1.10.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpcapsourcejessie(not affected)
libpcapsourcestretch(not affected)
libpcapsourcebuster(not affected)
libpcapsource(unstable)1.9.1-1unimportant

Notes

[buster] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
[stretch] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
[jessie] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
https://github.com/the-tcpdump-group/libpcap/commit/617b12c0339db4891d117b661982126c495439ea
rpcapd not built in Debian.

Search for package or bug name: Reporting problems