CVE-2019-15162

NameCVE-2019-15162
Descriptionrpcapd/daemon.c in libpcap before 1.9.1 on non-Windows platforms provides details about why authentication failed, which might make it easier for attackers to enumerate valid usernames.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpcap (PTS)jessie1.6.2-2fixed
stretch1.8.1-3fixed
buster1.8.1-6fixed
bullseye, sid1.9.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpcapsource(unstable)1.9.1-1unimportant
libpcapsourcebuster(not affected)
libpcapsourcejessie(not affected)
libpcapsourcestretch(not affected)

Notes

[buster] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
[stretch] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
[jessie] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
https://github.com/the-tcpdump-group/libpcap/commit/484d60cbf7ca4ec758c3cbb8a82d68b244a78d58
rpcapd not build in Debian.

Search for package or bug name: Reporting problems