CVE-2019-15164

NameCVE-2019-15164
Descriptionrpcapd/daemon.c in libpcap before 1.9.1 allows SSRF because a URL may be provided as a capture source.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpcap (PTS)stretch1.8.1-3fixed
stretch (security)1.8.1-3+deb9u1fixed
buster1.8.1-6+deb10u1fixed
bullseye1.10.0-2fixed
bookworm, sid1.10.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpcapsourcejessie(not affected)
libpcapsourcestretch(not affected)
libpcapsourcebuster(not affected)
libpcapsource(unstable)1.9.1-1unimportant

Notes

[buster] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
[stretch] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
[jessie] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
https://github.com/the-tcpdump-group/libpcap/commit/33834cb2a4d035b52aa2a26742f832a112e90a0a
rpcapd not build in Debian.

Search for package or bug name: Reporting problems