CVE-2019-15165

NameCVE-2019-15165
Descriptionsf-pcapng.c in libpcap before 1.9.1 does not properly validate the PHB header length before allocating memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1967-1
NVD severitymedium
Debian Bugs941697

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpcap (PTS)jessie1.6.2-2vulnerable
jessie (security)1.6.2-2+deb8u1fixed
stretch1.8.1-3vulnerable
buster1.8.1-6vulnerable
bullseye, sid1.9.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpcapsource(unstable)1.9.1-1low941697
libpcapsourcejessie1.6.2-2+deb8u1DLA-1967-1

Notes

[buster] - libpcap <no-dsa> (Minor issue)
[stretch] - libpcap <no-dsa> (Minor issue)
https://github.com/the-tcpdump-group/libpcap/commit/87d6bef033062f969e70fa40c43dfd945d5a20ab
https://github.com/the-tcpdump-group/libpcap/commit/a5a36d9e82dde7265e38fe1f87b7f11c461c29f6

Search for package or bug name: Reporting problems