CVE-2019-15232

NameCVE-2019-15232
DescriptionLive555 before 2019.08.16 has a Use-After-Free because GenericMediaServer::createNewClientSessionWithId can generate the same client session ID in succession, which is mishandled by the MPEG1or2 and Matroska file demultiplexors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblivemedia (PTS)jessie2014.01.13-1vulnerable
jessie (security)2014.01.13-1+deb8u3vulnerable
stretch (security), stretch2016.11.28-1+deb9u2vulnerable
bullseye, sid, buster2018.11.26-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblivemediasource(unstable)(unfixed)low

Notes

[buster] - liblivemedia <postponed> (Can be fixed along in future update)
[stretch] - liblivemedia <postponed> (Can be fixed along in future update)
[jessie] - liblivemedia <postponed> (Can be fixed along with more important patches)
Fixed upstream in 2019.08.16 according to available information.

Search for package or bug name: Reporting problems