CVE-2019-15691

NameCVE-2019-15691
DescriptionTigerVNC version prior to 1.10.1 is vulnerable to stack use-after-retu ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs947428

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tigervnc (PTS)stretch1.7.0+dfsg-7+deb9u1fixed
buster1.9.0+dfsg-3+deb10u1fixed
bullseye, sid1.10.1+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tigervncsource(unstable)1.10.1+dfsg-1947428
tigervncsourcebuster1.9.0+dfsg-3+deb10u1
tigervncsourcestretch1.7.0+dfsg-7+deb9u1

Notes

https://www.openwall.com/lists/oss-security/2019/12/20/2
https://github.com/TigerVNC/tigervnc/commit/d61a767d6842b530ffb532ddd5a3d233119aad40 (master)
https://github.com/TigerVNC/tigervnc/commit/042de4642293df9b72a08189c249e2da79cbca91 (v1.10.1)

Search for package or bug name: Reporting problems