CVE-2019-15695

NameCVE-2019-15695
DescriptionTigerVNC version prior to 1.10.1 is vulnerable to stack buffer overflow, which could be triggered from CMsgReader::readSetCursor. This vulnerability occurs due to insufficient sanitization of PixelFormat. Since remote attacker can choose offset from start of the buffer to start writing his values, exploitation of this vulnerability could potentially result into remote code execution. This attack appear to be exploitable via network connectivity.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs947428

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tigervnc (PTS)stretch1.7.0+dfsg-7vulnerable
buster1.9.0+dfsg-3vulnerable
bullseye, sid1.10.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tigervncsource(unstable)1.10.1+dfsg-1947428

Notes

[buster] - tigervnc <no-dsa> (Minor issue; can be fixed via point release)
[stretch] - tigervnc <no-dsa> (Minor issue; can be fixed via point release)
https://www.openwall.com/lists/oss-security/2019/12/20/2
https://github.com/TigerVNC/tigervnc/commit/05e28490873a861379c943bf616614b78b558b89 (master)
https://github.com/TigerVNC/tigervnc/commit/6c47340e095258a959c95db9aa2a6c715d62bf7c (v1.10.1)

Search for package or bug name: Reporting problems