DescriptionIrssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs936074

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)stretch, stretch (security)1.0.7-1~deb9u1fixed
bookworm, sid, bullseye1.2.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisourcejessie(not affected)
irssisourcestretch(not affected)


[buster] - irssi <no-dsa> (Minor issue)
[stretch] - irssi <not-affected> (Vulnerable code not present)
[jessie] - irssi <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems