CVE-2019-15846

NameCVE-2019-15846
DescriptionExim before 4.92.2 allows remote attackers to execute arbitrary code as root via a trailing backslash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1911-1, DSA-4517-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)buster4.92-8+deb10u6fixed
buster (security)4.92-8+deb10u9fixed
bullseye (security), bullseye4.94.2-7+deb11u2fixed
bookworm, bookworm (security)4.96-15+deb12u4fixed
sid, trixie4.97-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4sourcejessie4.84.2-2+deb8u6DLA-1911-1
exim4sourcestretch4.89-2+deb9u6DSA-4517-1
exim4sourcebuster4.92-8+deb10u2DSA-4517-1
exim4source(unstable)4.92.1-3

Notes

https://www.openwall.com/lists/oss-security/2019/09/04/1
https://git.exim.org/exim.git/commit/2600301ba6dbac5c9d640c87007a07ee6dcea1f4

Search for package or bug name: Reporting problems