CVE-2019-15902

NameCVE-2019-15902
DescriptionA backporting error was discovered in the Linux stable/longterm kernel 4.4.x through 4.4.190, 4.9.x through 4.9.190, 4.14.x through 4.14.141, 4.19.x through 4.19.69, and 5.2.x through 5.2.11. Misuse of the upstream "x86/ptrace: Fix possible spectre-v1 in ptrace_get_debugreg()" commit reintroduced the Spectre vulnerability that it aimed to eliminate. This occurred because the backport process depends on cherry picking specific commits, and because two (correctly ordered) code lines were swapped.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1940-1, DSA-4531-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.210-1fixed
stretch (security)4.9.210-1+deb9u1fixed
buster4.19.118-2fixed
buster (security)4.19.118-2+deb10u1fixed
bullseye, sid5.7.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.2.17-1
linuxsourcebuster4.19.67-2+deb10u1DSA-4531-1
linuxsourcejessie(not affected)
linuxsourcestretch4.9.189-3+deb9u1DSA-4531-1
linux-4.9sourcejessie4.9.189-3+deb9u1~deb8u1DLA-1940-1

Notes

[jessie] - linux <not-affected> (Bug never introduced)
https://grsecurity.net/teardown_of_a_failed_linux_lts_spectre_fix.php

Search for package or bug name: Reporting problems