CVE-2019-15903

NameCVE-2019-15903
DescriptionIn libexpat before 2.2.8, crafted XML input could fool the parser into changing from DTD parsing to document parsing too early; a consecutive call to XML_GetCurrentLineNumber (or XML_GetCurrentColumnNumber) then resulted in a heap-based buffer over-read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1912-1, DSA-4530-1
NVD severitymedium (attack range: remote)
Debian Bugs939394

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
expat (PTS)jessie2.1.0-6+deb8u4vulnerable
jessie (security)2.1.0-6+deb8u6fixed
stretch2.2.0-2+deb9u2vulnerable
stretch (security)2.2.0-2+deb9u3fixed
buster2.2.6-2vulnerable
buster (security)2.2.6-2+deb10u1fixed
bullseye, sid2.2.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
expatsource(unstable)2.2.7-2medium939394
expatsourcebuster2.2.6-2+deb10u1mediumDSA-4530-1
expatsourcejessie2.1.0-6+deb8u6mediumDLA-1912-1
expatsourcestretch2.2.0-2+deb9u3mediumDSA-4530-1

Notes

https://github.com/libexpat/libexpat/commit/c20b758c332d9a13afbbb276d30db1d183a85d43
https://github.com/libexpat/libexpat/issues/317
https://github.com/libexpat/libexpat/pull/318

Search for package or bug name: Reporting problems