CVE-2019-16391

NameCVE-2019-16391
DescriptionSPIP before 3.1.11 and 3.2 before 3.2.5 allows authenticated visitors to modify any published content and execute other modifications in the database. This is related to ecrire/inc/meta.php and ecrire/inc/securiser_action.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4532-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)jessie (security), jessie3.0.17-2+deb8u4vulnerable
stretch3.1.4-4~deb9u2vulnerable
stretch (security)3.1.4-4~deb9u3fixed
buster3.2.4-1vulnerable
buster (security)3.2.4-1+deb10u1fixed
bullseye, sid3.2.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsource(unstable)3.2.5-1medium
spipsourcebuster3.2.4-1+deb10u1mediumDSA-4532-1
spipsourcestretch3.1.4-4~deb9u3mediumDSA-4532-1

Notes

https://git.spip.net/SPIP/spip/commit/187952ce85e73b52c2753f2d54fc2c44807b8f79
https://git.spip.net/SPIP/spip/commit/3cbc758400323ab006c00ea78eacdb8f76aa5f66

Search for package or bug name: Reporting problems