CVE-2019-16392

NameCVE-2019-16392
DescriptionSPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4532-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)jessie (security), jessie3.0.17-2+deb8u4vulnerable
stretch3.1.4-4~deb9u2vulnerable
stretch (security)3.1.4-4~deb9u3fixed
buster3.2.4-1vulnerable
buster (security)3.2.4-1+deb10u1fixed
bullseye, sid3.2.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsource(unstable)3.2.5-1medium
spipsourcebuster3.2.4-1+deb10u1mediumDSA-4532-1
spipsourcestretch3.1.4-4~deb9u3mediumDSA-4532-1

Notes

https://git.spip.net/SPIP/spip/commit/3c12a82c7d9d4afd09e708748fa82e7836174028

Search for package or bug name: Reporting problems