CVE-2019-16394

NameCVE-2019-16394
DescriptionSPIP before 3.1.11 and 3.2 before 3.2.5 provides different error messages from the password-reminder page depending on whether an e-mail address exists, which might help attackers to enumerate subscribers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1975-1, DSA-4532-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)jessie3.0.17-2+deb8u4vulnerable
jessie (security)3.0.17-2+deb8u5fixed
stretch3.1.4-4~deb9u2vulnerable
stretch (security)3.1.4-4~deb9u3fixed
buster, buster (security)3.2.4-1+deb10u1fixed
bullseye, sid3.2.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsource(unstable)3.2.5-1
spipsourcebuster3.2.4-1+deb10u1DSA-4532-1
spipsourcejessie3.0.17-2+deb8u5DLA-1975-1
spipsourcestretch3.1.4-4~deb9u3DSA-4532-1

Notes

https://core.spip.net/issues/4171
https://zone.spip.net/trac/spip-zone/changeset/117577/spip-zone
https://zone.spip.net/trac/spip-zone/changeset/117578/spip-zone

Search for package or bug name: Reporting problems