CVE-2019-16789

NameCVE-2019-16789
DescriptionIn Waitress through version 1.4.0, if a proxy server is used in front ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2056-1, DLA-3000-1
Debian Bugs947433

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
waitress (PTS)buster1.2.0~b2-2vulnerable
buster (security)1.2.0~b2-2+deb10u1fixed
bullseye1.4.4-1.1fixed
bullseye (security)1.4.4-1.1+deb11u1fixed
bookworm, sid2.1.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
waitresssourcejessie0.8.9-2+deb8u1DLA-2056-1
waitresssourcestretch1.0.1-1+deb9u1DLA-3000-1
waitresssourcebuster1.2.0~b2-2+deb10u1
waitresssource(unstable)1.4.1-1947433

Notes

https://github.com/Pylons/waitress/security/advisories/GHSA-m5ff-3wj3-8ph4
https://github.com/Pylons/waitress/commit/11d9e138125ad46e951027184b13242a3c1de017

Search for package or bug name: Reporting problems