CVE-2019-16928

NameCVE-2019-16928
DescriptionExim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019-15846. There is a heap-based buffer overflow in string_vformat in string.c involving a long EHLO command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4536-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)jessie4.84.2-2+deb8u5fixed
jessie (security)4.84.2-2+deb8u6fixed
stretch4.89-2+deb9u5fixed
stretch (security)4.89-2+deb9u6fixed
buster4.92-8+deb10u1vulnerable
buster (security)4.92-8+deb10u3fixed
bullseye, sid4.92.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4source(unstable)4.92.2-3high
exim4sourcebuster4.92-8+deb10u3highDSA-4536-1
exim4sourcejessie(not affected)
exim4sourcestretch(not affected)

Notes

[stretch] - exim4 <not-affected> (Vulnerable code introduced later)
[jessie] - exim4 <not-affected> (Vulnerable code introduced later)
https://lists.exim.org/lurker/message/20190927.032457.c1044d4c.en.html
https://bugs.exim.org/show_bug.cgi?id=2449
https://git.exim.org/exim.git/commit/478effbfd9c3cc5a627fc671d4bf94d13670d65f

Search for package or bug name: Reporting problems