CVE-2019-17017

NameCVE-2019-17017
DescriptionDue to a missing case handling object types, a type confusion vulnerability could occur, resulting in a crash. We presume that with enough effort that it could be exploited to run arbitrary code. This vulnerability affects Firefox ESR < 68.4 and Firefox < 72.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2061-1, DLA-2071-1, DSA-4600-1, DSA-4603-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid80.0.1-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1fixed
stretch (security)68.12.0esr-1~deb9u1fixed
buster68.10.0esr-1~deb10u1fixed
buster (security)68.12.0esr-1~deb10u1fixed
bullseye68.11.0esr-1fixed
sid78.2.0esr-1fixed
thunderbird (PTS)stretch1:68.10.0-1~deb9u1fixed
stretch (security)1:68.12.0-1~deb9u2fixed
buster1:68.10.0-1~deb10u1fixed
buster (security)1:68.12.0-1~deb10u1fixed
bullseye, sid1:68.12.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)72.0-1
firefox-esrsourcejessie68.4.0esr-1~deb8u1DLA-2061-1
firefox-esrsourcestretch68.4.1esr-1~deb9u1DSA-4600-1
firefox-esrsourcebuster68.4.1esr-1~deb10u1DSA-4600-1
firefox-esrsource(unstable)68.4.0esr-1
thunderbirdsourcejessie1:68.4.1-1~deb8u1DLA-2071-1
thunderbirdsourcestretch1:68.4.1-1~deb9u1DSA-4603-1
thunderbirdsourcebuster1:68.4.1-1~deb10u1DSA-4603-1
thunderbirdsource(unstable)1:68.4.1-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2020-01/#CVE-2019-17017
https://www.mozilla.org/en-US/security/advisories/mfsa2020-02/#CVE-2019-17017
https://www.mozilla.org/en-US/security/advisories/mfsa2020-04/#CVE-2019-17017

Search for package or bug name: Reporting problems