CVE-2019-17024

NameCVE-2019-17024
DescriptionMozilla developers reported memory safety bugs present in Firefox 71 and Firefox ESR 68.3. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox ESR < 68.4 and Firefox < 72.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2061-1, DSA-4600-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid72.0.1-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1vulnerable
jessie (security)68.4.0esr-1~deb8u1fixed
stretch60.7.1esr-1~deb9u1vulnerable
stretch (security)68.4.1esr-1~deb9u1fixed
buster68.2.0esr-1~deb10u1vulnerable
buster (security)68.4.1esr-1~deb10u1fixed
bullseye, sid68.4.1esr-1fixed
thunderbird (PTS)jessie1:52.8.0-1~deb8u1vulnerable
jessie (security)1:68.3.0-2~deb8u1vulnerable
stretch1:60.8.0-1~deb9u1vulnerable
stretch (security)1:68.3.0-2~deb9u1vulnerable
buster1:60.9.0-1~deb10u1vulnerable
buster (security)1:68.3.0-2~deb10u1vulnerable
bullseye1:60.9.0-1vulnerable
sid1:68.4.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)72.0-1
firefox-esrsource(unstable)68.4.0esr-1
firefox-esrsourcebuster68.4.1esr-1~deb10u1DSA-4600-1
firefox-esrsourcejessie68.4.0esr-1~deb8u1DLA-2061-1
firefox-esrsourcestretch68.4.1esr-1~deb9u1DSA-4600-1
thunderbirdsource(unstable)1:68.4.1-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2020-01/#CVE-2019-17024
https://www.mozilla.org/en-US/security/advisories/mfsa2020-02/#CVE-2019-17024
https://www.mozilla.org/en-US/security/advisories/mfsa2020-04/#CVE-2019-17024

Search for package or bug name: Reporting problems