CVE-2019-17401

NameCVE-2019-17401
Description** DISPUTED ** libyal liblnk 20191006 has a heap-based buffer over-read in the network_share_name_offset>20 code block of liblnk_location_information_read_data in liblnk_location_information.c, a different issue than CVE-2019-17264. NOTE: the vendor has disputed this as described in the GitHub issue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblnk (PTS)stretch20170111-1vulnerable
bullseye, sid, buster20181227-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblnksource(unstable)(unfixed)low

Notes

[buster] - liblnk <no-dsa> (Minor issue)
[stretch] - liblnk <no-dsa> (Minor issue)
https://github.com/libyal/liblnk/issues/40

Search for package or bug name: Reporting problems