CVE-2019-17542

NameCVE-2019-17542
DescriptionFFmpeg before 4.2 has a heap-based buffer overflow in vqa_decode_chunk because of an out-of-array access in vqa_decode_init in libavcodec/vqavideo.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch (security), stretch7:3.2.14-1~deb9u1vulnerable
buster, buster (security)7:4.1.4-1~deb10u1vulnerable
bullseye, sid7:4.2.1-2fixed
libav (PTS)jessie6:11.12-1~deb8u1vulnerable
jessie (security)6:11.12-1~deb8u8vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:4.2.1-1
libavsource(unstable)(unfixed)

Notes

[buster] - ffmpeg <postponed> (Minor issue, wait until fixed in 4.1.x branch)
[stretch] - ffmpeg <postponed> (Minor issue, wait until fixed in 3.2.x branch)
https://github.com/FFmpeg/FFmpeg/commit/02f909dc24b1f05cfbba75077c7707b905e63cd2

Search for package or bug name: Reporting problems