CVE-2019-17560

NameCVE-2019-17560
DescriptionThe "Apache NetBeans" autoupdate system does not validate SSL certificates and hostnames for https based downloads. This allows an attacker to intercept downloads of autoupdates and modify the download, potentially injecting malicious code. ÔÇťApache NetBeans" versions up to and including 11.2 are affected by this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netbeans (PTS)stretch8.1+dfsg3-2vulnerable
sid10.0-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netbeanssource(unstable)(unfixed)unimportant

Notes

Debian packages updated via apt

Search for package or bug name: Reporting problems