CVE-2019-17561

NameCVE-2019-17561
DescriptionThe "Apache NetBeans" autoupdate system does not fully validate code signatures. An attacker could modify the downloaded nbm and include additional code. "Apache NetBeans" versions up to and including 11.2 are affected by this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netbeans (PTS)stretch8.1+dfsg3-2vulnerable
bookworm, sid, bullseye12.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netbeanssource(unstable)12.1-1unimportant

Notes

Debian packages updated via apt, starting with 12.1 only some classes are shipped

Search for package or bug name: Reporting problems