CVE-2019-17670

NameCVE-2019-17670
DescriptionWordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1980-1, DLA-2371-1
NVD severityhigh
Debian Bugs942459

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch4.7.5+dfsg-2+deb9u6vulnerable
stretch (security)4.7.19+dfsg-1+deb9u1fixed
buster5.0.10+dfsg1-0+deb10u1vulnerable
buster (security)5.0.11+dfsg1-0+deb10u1vulnerable
bullseye5.5.1+dfsg1-1fixed
sid5.5.3+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcejessie4.1.28+dfsg-0+deb8u1DLA-1980-1
wordpresssourcestretch4.7.18+dfsg-1+deb9u1DLA-2371-1
wordpresssource(unstable)5.2.4+dfsg1-1942459

Notes

[buster] - wordpress <no-dsa> (Minor issue)
https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
https://core.trac.wordpress.org/changeset/46472
https://github.com/WordPress/WordPress/commit/9db44754b9e4044690a6c32fd74b9d5fe26b07b2
https://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/

Search for package or bug name: Reporting problems