CVE-2019-18397

NameCVE-2019-18397
DescriptionA buffer overflow in the fribidi_get_par_embedding_levels_ex() function in lib/fribidi-bidi.c of GNU FriBidi through 1.0.7 allows an attacker to cause a denial of service or possibly execute arbitrary code by delivering crafted text content to a user, when this content is then rendered by an application that uses FriBidi for text layout calculations. Examples include any GNOME or GTK+ based application that uses Pango for text layout, as this internally uses FriBidi for bidirectional text layout. For example, the attacker can construct a crafted text file to be opened in GEdit, or a crafted IRC message to be viewed in HexChat.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4561-1
Debian Bugs944327

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fribidi (PTS)jessie0.19.6-3fixed
stretch0.19.7-1+deb9u1fixed
buster, buster (security)1.0.5-3.1+deb10u1fixed
bullseye, sid1.0.7-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fribidisource(unstable)1.0.7-1.1944327
fribidisourcebuster1.0.5-3.1+deb10u1DSA-4561-1
fribidisourcejessie(not affected)
fribidisourcestretch(not affected)

Notes

[stretch] - fribidi <not-affected> (Vulnerable code not present)
[jessie] - fribidi <not-affected> (Vulnerable code not present)
Fixed by: https://github.com/fribidi/fribidi/commit/034c6e9a1d296286305f4cfd1e0072b879f52568
Introduced by: https://github.com/fribidi/fribidi/commit/f20b6480b9cd46dae8d82a6f95d9c53558fcfd20 (v1.0.0)

Search for package or bug name: Reporting problems