DescriptionUniValue::read() in UniValue before 1.0.5 allow attackers to cause a denial of service (the class internal data reaches an inconsistent state) via input data that triggers an error.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs954959

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libunivalue (PTS)stretch1.0.2-3vulnerable
bookworm, sid, bullseye1.1.1+20191112-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[buster] - libunivalue <no-dsa> (Minor issue)
[stretch] - libunivalue <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems