CVE-2019-18936

NameCVE-2019-18936
DescriptionUniValue::read() in UniValue before 1.0.5 allow attackers to cause a denial of service (the class internal data reaches an inconsistent state) via input data that triggers an error.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs954959

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libunivalue (PTS)stretch1.0.2-3vulnerable
buster1.0.4-2vulnerable
bullseye, sid1.1.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libunivaluesource(unstable)1.1.1-2954959

Notes

[buster] - libunivalue <no-dsa> (Minor issue)
[stretch] - libunivalue <no-dsa> (Minor issue)
https://github.com/jgarzik/univalue/commit/07aa635c034f3a2accfe4e20a8148c366bccf5bf
https://github.com/jgarzik/univalue/pull/58

Search for package or bug name: Reporting problems