CVE-2019-19074

NameCVE-2019-19074
DescriptionA memory leak in the ath9k_wmi_cmd() function in drivers/net/wireless/ath/ath9k/wmi.c in the Linux kernel through 5.3.11 allows attackers to cause a denial of service (memory consumption), aka CID-728c1e2a05e4.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2385-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1vulnerable
stretch (security)4.9.210-1+deb9u1vulnerable
buster4.19.146-1fixed
buster (security)4.19.118-2+deb10u1vulnerable
bullseye, sid5.8.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcebuster4.19.146-1
linuxsource(unstable)5.4.6-1

Notes

https://git.kernel.org/linus/728c1e2a05e4b5fc52fab3421dce772a806612a2

Search for package or bug name: Reporting problems