CVE-2019-19534

NameCVE-2019-19534
DescriptionIn the Linux kernel before 5.3.11, there is an info-leak bug that can be caused by a malicious USB device in the drivers/net/can/usb/peak_usb/pcan_usb_core.c driver, aka CID-f7a1337f0d29.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2068-1, DLA-2114-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1fixed
stretch (security)4.9.210-1+deb9u1fixed
buster4.19.146-1fixed
buster (security)4.19.152-1fixed
bullseye, sid5.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie3.16.81-1DLA-2068-1
linuxsourcestretch4.9.210-1
linuxsourcebuster4.19.87-1
linuxsource(unstable)5.3.15-1
linux-4.9sourcejessie4.9.210-1~deb8u1DLA-2114-1

Notes

https://git.kernel.org/linus/f7a1337f0d29b98733c8824e165fca3371d7d4fd

Search for package or bug name: Reporting problems