CVE-2019-19582

NameCVE-2019-19582
DescriptionAn issue was discovered in Xen through 4.12.x allowing x86 guest OS users to cause a denial of service (infinite loop) because certain bit iteration is mishandled. In a number of places bitmaps are being used by the hypervisor to track certain state. Iteration over all bits involves functions which may misbehave in certain corner cases: On x86 accesses to bitmaps with a compile time known size of 64 may incur undefined behavior, which may in particular result in infinite loops. A malicious guest may cause a hypervisor crash or hang, resulting in a Denial of Service (DoS). All versions of Xen are vulnerable. x86 systems with 64 or more nodes are vulnerable (there might not be any such systems that Xen would run on). x86 systems with less than 64 nodes are not vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4602-1
NVD severitylow
Debian Bugs947944

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie4.4.1-9+deb8u10vulnerable
jessie (security)4.4.4lts5-0+deb8u1vulnerable
stretch4.8.5+shim4.10.2+xsa282-1+deb9u11vulnerable
stretch (security)4.8.5.final+shim4.10.4-1+deb9u12fixed
buster4.11.1+92-g6c33308a8d-2vulnerable
buster (security)4.11.3+24-g14b62ab3e5-1~deb10u1fixed
bullseye, sid4.11.3+24-g14b62ab3e5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.11.3+24-g14b62ab3e5-1947944
xensourcebuster4.11.3+24-g14b62ab3e5-1~deb10u1DSA-4602-1
xensourcestretch4.8.5.final+shim4.10.4-1+deb9u12DSA-4602-1

Notes

https://xenbits.xen.org/xsa/advisory-307.html

Search for package or bug name: Reporting problems