DescriptionArbitrary command execution is possible in Git before 2.20.2, 2.21.x before 2.21.1, 2.22.x before 2.22.2, 2.23.x before 2.23.1, and 2.24.x before 2.24.1 because a "git submodule update" operation can run commands found in the .gitmodules file of a malicious repository.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
git (PTS)buster1:2.20.1-2+deb10u3fixed
buster (security)1:2.20.1-2+deb10u8fixed
bullseye (security), bullseye1:2.30.2-1+deb11u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitsourcejessie(not affected)
gitsourcestretch(not affected)


[stretch] - git <not-affected> (Vulnerable code introduced in v2.20.0-rc0)
[jessie] - git <not-affected> (Vulnerable code introduced in v2.20.0-rc0)
Upstream did backport fixes for CVE-2019-19604 to older versions as the introducing
version for sake of robustness/hardening. In particular, the server-side protection
provided by the fsck is useful for protecting unpatched clients that are affected
by the bug.

Search for package or bug name: Reporting problems