CVE-2019-19728

NameCVE-2019-19728
DescriptionSchedMD Slurm before 18.08.9 and 19.x before 19.05.5 executes srun --uid with incorrect privileges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)jessie14.03.9-5+deb8u2vulnerable
jessie (security)14.03.9-5+deb8u4vulnerable
stretch16.05.9-1+deb9u4vulnerable
stretch (security)16.05.9-1+deb9u2vulnerable
buster18.08.5.2-1vulnerable
buster (security)18.08.5.2-1+deb10u1vulnerable
bullseye19.05.3.2-2vulnerable
sid19.05.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsource(unstable)19.05.5-1

Notes

[buster] - slurm-llnl <no-dsa> (Minor issue)
[stretch] - slurm-llnl <no-dsa> (Minor issue)
https://bugzilla.suse.com/show_bug.cgi?id=1159692
Fixed upstream in 18.08.9, 19.05.5

Search for package or bug name: Reporting problems