CVE-2019-19905

NameCVE-2019-19905
DescriptionNetHack 3.6.x before 3.6.4 is prone to a buffer overflow vulnerability when reading very long lines from configuration files. This affects systems that have NetHack installed suid/sgid, and shared systems that allow users to upload their own configuration files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs947005

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nethack (PTS)jessie3.4.3-15vulnerable
stretch3.6.0-4vulnerable
sid, buster3.6.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nethacksource(unstable)(unfixed)unimportant947005

Notes

https://github.com/NetHack/NetHack/commit/f4a840a48f4bcf11757b3d859e9d53cc9d5ef226
https://github.com/NetHack/NetHack/commit/f001de79542b8c38b1f8e6d7eaefbbd28ab94b47
Negligible security impact

Search for package or bug name: Reporting problems