CVE-2019-19918

NameCVE-2019-19918
DescriptionLout 3.40 has a heap-based buffer overflow in the srcnext() function in z02.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs947113

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lout (PTS)jessie3.39-1vulnerable
sid, buster, stretch3.39-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
loutsource(unstable)(unfixed)947113

Notes

[buster] - lout <no-dsa> (Minor issue)
[stretch] - lout <no-dsa> (Minor issue)
[jessie] - lout <ignored> (Minor issue)
https://lists.gnu.org/archive/html/lout-users/2019-12/msg00001.html

Search for package or bug name: Reporting problems