CVE-2019-20378

NameCVE-2019-20378
Descriptionganglia-web (aka Ganglia Web Frontend) through 3.7.5 allows XSS via the header.php ce parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs948664

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ganglia-web (PTS)jessie3.6.1-1vulnerable
buster, bullseye, stretch, sid3.6.1-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ganglia-websource(unstable)(unfixed)unimportant948664

Notes

https://github.com/ganglia/ganglia-web/issues/351
See README.Debian.security, only supported behind an authenticated HTTP zone, #702776

Search for package or bug name: Reporting problems