CVE-2019-20393

NameCVE-2019-20393
DescriptionA double-free is present in libyang before v1.0-r1 in the function yyparse() when an empty description is used. Applications that use libyang to parse untrusted input yang files may be vulnerable to this flaw, which would cause a crash or potentially code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libyang (PTS)buster0.16.105-1vulnerable
bullseye, sid0.16.105-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libyangsource(unstable)(unfixed)

Notes

[buster] - libyang <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1793930
https://github.com/CESNET/libyang/commit/d9feacc4a590d35dbc1af21caf9080008b4450ed
https://github.com/CESNET/libyang/issues/742

Search for package or bug name: Reporting problems